GSB 10.8 2 Li overheating and cut out
Activity
Sector experience since
not enabled
Sector
Other building trade
Written on
2 years old, OOW, the light/battery indicator still works but the motor does not activate. This happenend yesterday, due to overheating whilst cutting 10mm porcelain tiles, with the completely useless Erbauer dry diamond drill bit (on the 4th hole). I've left it overnight to cool down, but there is no repsonse from the motor. The User guide doesn't have a trouble shooting section either.

Can it be repaired does anyone know?

Where's the nearest repair centre to Woking, Surrey?

Thanks for any help.

This post was edited by dougie on 19.02.2018, 07:01 o’clock
Reason: Add a comment.

Activity
Sector experience since
not enabled
Sector
Other building trade
Written on
Sorted! Even though I'd left the drill overnight, it did not work this morning, other than the light/battery indicator. It then struck me, take the battery out for a few minutes and try again. 

I'm pleased to say the drill works again!! One very happy chap!!
Activity
Sector experience since
not enabled
Sector
Joinery installation in the broadest sense
Written on
Glad it's sorted Dougie. As a general rule, this is the best place to start when a cordless tool cuts out - remove, wait a few seconds, then replace the battery.
Activity
Sector experience since
not enabled
Sector
Joinery installation in the broadest sense
Written on
In my experience this is a battery issue and will get worse with that particular battery.  The battery level indicator lights show the state of charge of the battery, but the motor does not run.  I recently got rid of all my original 1.3Ah batteries as they were all doing it off and on - I am now seeing it on just one of my 2.0Ah batteries.  I mark the battery with a sharpie so I can make sure it only happens on one battery.  I have six tools and five batteries at the moment, the fault is the same on each tool. (Although the recip saw shows a red battery warning light too when the motor doesn't run - none of my other tools have that indicator.)
Activity
Sector experience since
not enabled
Sector
Joinery installation in the broadest sense
Written on
In my experience this is a battery issue and will get worse with that particular battery.  The battery level indicator lights show the state of charge of the battery, but the motor does not run.  I recently got rid of all my original 1.3Ah batteries as they were all doing it off and on - I am now seeing it on just one of my 2.0Ah batteries.  I mark the battery with a sharpie so I can make sure it only happens on one battery.  I have six tools and five batteries at the moment, the fault is the same on each tool. (Although the recip saw shows a red battery warning light too when the motor doesn't run - none of my other tools have that indicator.)
Activity
Sector experience since
not enabled
Sector
Other building trade
Written on
Thanks legnumnick, I'll try that! I do have 1 problem battery, which is the 1.3Ah. I'll mark it and keep an eye on it. I have about 5/6 batteries too but might swap out the older 3.