GSR 10,8 V-EC
Activity
Sector experience since
not enabled
Sector
Electrical installation
Written on
I have two GSR 10,8 V-EC(one is HX)  that I bought in 2015(which are now our of warrantry) .  In the last 3 weeks both drills have started to work intermittently when pulling the triggers. Though when they do activate they are the same power as normal and do not cut out. Upon acitvation they seem to run well intill they are left alone and then start to play up again.

What is really bugging me about this problem is the fact both drills within weeks of each other are having the same prbolem but the amount of work the drills have done compared to each other over the past 3 years, I would guess is over 95%  less hours used. 

From what i have read its something to do with the softstart and would need a new eletroniocs module which is nearly the price of an entirely new unit. Does anyone know if they is a likely cuase and if there is a cheaper soloution? 

It does make me wonder if Bosch  purposely use componets with lifespans just longer than the units warrantry. :/
Activity
Sector experience since
not enabled
Sector
Electrical installation
Written on
i had same problem with the same series. the chip in electronic modul was burning, the chip was unknown manufacture, i cant search for component
Activity
Sector experience since
not enabled
Sector
Joinery installation in the broadest sense
Written on
Mark the batteries and see if it is common to particular batteries. I had a couple of failing batteries and that was ecactly the symptom. The battery status monitor would show fully charged but the motor didn't turn.